LuxSci Network Down in Texas
Incident Report for LuxSci
Resolved
This incident is apparently resolved. From Rackspace:

"On 4 August 2020, between 22:21 CDT and 23:07 CDT, customers in the DFW3 data center may have experienced packet loss, latency, or loss of connectivity. Network Operations engineers are investigating root cause and are monitoring the environment's stability."
Posted Aug 05, 2020 - 00:40 EDT
Monitoring
Rackspace appears to have resolved the networking issue as our servers are back online. We are moving this to "Monitoring" until we have an update from them and confirm that all is better.
Posted Aug 05, 2020 - 00:14 EDT
Identified
We have identified the issue as an incident in the Rackspace Dallas data center that is affecting network traffic to and from our infrastructure located there ... as well as impacting many other Rackspace customers located in the same data center. We are working to gather more information from Rackspace on the issue, as there is not yet a public status update from them on it.
Posted Aug 05, 2020 - 00:05 EDT
Update
We are continuing to investigate this issue.
Posted Aug 04, 2020 - 23:56 EDT
Investigating
We are currently investigating and issue where the LuxSci network in Dallas Texas appears inaccessible.
Posted Aug 04, 2020 - 23:34 EDT
This incident affected: LuxSci Network Infrastructure, Shared WebMail, SecureForm, LuxSci Secure Marketing v2, Hosted Email, and Hosted Web Services.