Premium Email Filtering Experiencing Delays
Incident Report for LuxSci
Resolved
The email delay issues with our Premium Email Filtering service should be resolved at this time.
Posted 6 months ago. Apr 03, 2019 - 11:17 EDT
Investigating
We are currently seeing delivery delays for email going through our Premium Email Filtering service. The issue appears to be only affecting some filtered email at this time. We are investigating the issue at this time.
Posted 6 months ago. Apr 03, 2019 - 09:45 EDT
This incident affected: Premium Email Filtering.