Email Delay Affecting Proofpoint Customers

Incident Report for LuxSci

Resolved

The delay in delivery emails flowing through Proofpoint has been resolved. It may take a little while for Proofpoint to deliver all the email that was queued during this issue. No emails were lost during this issue.
Posted Jun 11, 2025 - 17:04 EDT

Investigating

You may be experiencing intermittent delays in receiving email being filtered by Proofpoint. We are aware of the delays and have a priority, escalated support ticket open with Proofpoint on this issue. We will update this notice as more information becomes available from Proofpoint.
Posted Jun 11, 2025 - 13:47 EDT
This incident affected: Premium Email Filtering.