WebMail issue
Incident Report for LuxSci
Resolved
An issue with one of our WebMail servers caused email to be unavailable to users who were logged into the affected WebMail server. The issue was investigated by our operations team and diagnosed as a database issue on the server. The database issue was resolved, and the server is now responding properly. A fix was put in place to prevent the database issue from recurring.
Posted Nov 13, 2023 - 13:35 EST
Investigating
We are currently investigating an issue with our Shared WebMail service. We will update this notice once it has been resolved.
Posted Nov 13, 2023 - 12:42 EST
This incident affected: Shared WebMail.