Degraded services due to server issues at our Phoenix data center

Incident Report for LuxSci

Resolved

Status: Resolved

Message:
Oracle has confirmed the issue affecting our Phoenix data center has been resolved. All services have returned to normal operation. We are sorry for any inconvenience this issue may have caused.
Posted Jul 15, 2026 - 19:53 EDT

Update

Oracle has updated us stating that their engineers are actively working to identify the root cause and restore normal service.. We do not yet have an ETA for when service will be fully restored.
Posted Jul 15, 2026 - 17:27 EDT

Investigating

An issue is affecting some servers at our Phoenix datacenter. Our data center provider Oracle is investigating the issue. Users may experience degraded services during this time.
Posted Jul 15, 2026 - 15:43 EDT
This incident affected: LuxSci Network Infrastructure, Shared WebMail, SecureForm, LuxSci Secure Marketing v3, Hosted Email, and Hosted Web Services.