We are experiencing some issues with network latency
Incident Report for LuxSci
Resolved
This issue is resolved.
Posted May 11, 2023 - 20:10 EDT
Monitoring
Our network is returning to normal operations. We will continue to monitor the situation.
Posted May 11, 2023 - 17:31 EDT
Investigating
We are experiencing network latency issues in our Ashburn, Virginia, data center. The network latency could cause webmail and website pages to load slowly. We are investigating the issue and hope to have it resolved soon.
Posted May 11, 2023 - 16:57 EDT
This incident affected: LuxSci Network Infrastructure, Shared WebMail, SecureForm, LuxSci Secure Marketing v2, Hosted Email, and Hosted Web Services.