Shared business class email server email405 down
Incident Report for LuxSci
Resolved
The server appears to be back online and functional at this time.
Posted 12 months ago. Oct 25, 2018 - 18:34 EDT
Investigating
Th business class email server used by some customers, email405, is currently down. This appears to be an issue with the underlying hypervisor. We are investigating the issue.

Affected users use email hostnames like "secure-email-405.luxsci.com" and "email405.luxsci.com".
Posted 12 months ago. Oct 25, 2018 - 18:08 EDT