Proofpoint Outage Affecting Some users With Premium Email Filtering

Incident Report for LuxSci

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 21:33 EST

Investigating

Proofpoint, our Premium Email Filtering provider, is experiencing issues that are affecting mail delivery. We have contacted Proofpoint regarding the issue. They are aware of the issue and are currently investigating it.

We will update this post once we have additional information.
Posted Jan 22, 2026 - 16:46 EST
This incident affected: Premium Email Filtering.