LuxSci System Issues
Incident Report for LuxSci
Resolved
We have resolved the issue with LuxSci services and will be providing more information as to the details of the outage as soon as possible.
Posted 11 months ago. Nov 14, 2018 - 12:52 EST
Investigating
We are currently investigating issues with LuxSci system services. We'll update when we have more information.
Posted 11 months ago. Nov 14, 2018 - 12:48 EST
This incident affected: Shared WebMail.