Webmail Issues
Incident Report for LuxSci
Resolved
The webmail issue has been resolved. All users should be able to access webmail at this time.
Posted Oct 17, 2022 - 16:30 EDT
Identified
LuxSci Is currently seeing some issues with webmail that are causing users to have problems logging In and staying connected to the site. Our Operations team is investigating the issue and we expect the problem will be resolved soon.
Posted Oct 17, 2022 - 15:58 EDT
This incident affected: Shared WebMail.