Proofpoint Email Delivery Delays
Incident Report for LuxSci
Resolved
Hello,

The issue of delayed emails through Proofpoint has been resolved at this time.

Thanks,
LuxSci support
Posted Apr 14, 2020 - 15:26 EDT
Investigating
Hello,

We're currently investigating an issue with delivery delays for customers using our Premium Email Filtering provider Proofpoint.

We'll update this status as we receive updates from Proofpoint.

Thanks,
LuxSci Support
Posted Apr 14, 2020 - 12:41 EDT
This incident affected: Premium Email Filtering.