MobileSync Intermittent Sync Delays

Incident Report for LuxSci

Resolved

The MobileSync issue has been resolved.
Posted May 30, 2025 - 14:45 EDT

Investigating

MobileSync users may experience intermittent sync delays with email or calendars. These delays are only impacting MobileSync and do not impact other integration options.
Posted May 30, 2025 - 10:18 EDT
This incident affected: Hosted Email.