Email Delivery Delay
Incident Report for LuxSci
Resolved
At this time, the issue with delayed email traveling through Proofpoint has been resolved. No email was lost during this time period.
Posted Jun 16, 2020 - 16:40 EDT
Monitoring
Proofpoint has identified the issue and has put measures in place to release any spooled email. We'll provide an update when this issue has been completely resolved.
Posted Jun 16, 2020 - 14:51 EDT
Investigating
Customers using our Premium Email Filtering service may be seeing delays in email delivery due to issues at Proofpoint. We are currently investigating the issue and will provide more information as it becomes available.
Posted Jun 16, 2020 - 12:30 EDT
This incident affected: Hosted Email.