Issue with luxSci Email Server rs158.luxsci.com
Incident Report for LuxSci
Resolved
The issue with LuxSci server rs158.luxsci.com is now resolved. If you have any questions regarding the incident, please open a ticket with our support team.
Posted Oct 10, 2019 - 16:16 EDT
Investigating
We are currently investigating an ongoing issue with LuxSci Email Server rs158.luxsci.com. Users on this server may experience issues with inbound and outbound email. We will provide more information as it becomes available.
Posted Oct 10, 2019 - 16:06 EDT
This incident affected: Hosted Email.