Webmail
Incident Report for LuxSci
Resolved
Webmail services are now fully operational, and no email was lost. Thank you all for your patience while we investigated and corrected this issue!
Posted 9 months ago. Jan 15, 2019 - 14:53 EST
Investigating
We are experiencing some technical difficulties with our LuxSci webmail services, and we are currently investigating. We will post updates here as soon as we have further information.
Posted 9 months ago. Jan 15, 2019 - 14:30 EST
This incident affected: Shared WebMail.